December 18

We’re happy to announce the release of the Sprint 156 edition of Quamotion. The version number of the current release is 1.4.38. The version number of the LTS release is 1.0.8.

xcuitrunner improvements

  • We’ve updated xcuitrunner to display an error message when a required dependency is not installed.
  • We’ve fixed an issue where the device would be in the locked state after starting WebDriverAgent.
  • We’ve improved the error message which is displayed when you launch xcuitrunner and no iOS devices are connected to your PC.
  • We’ve added support for launching xcuitrunner in combination with older and more recent versions of iproxy. xcuitrunner now supports the version of iproxy that ships with Ubuntu 20.04.
  • We’ve updated xcuitrunner to display an error message when you try to launch a test bundle which has been compiled for iOS simulators instead of iOS devices.
  • We’ve fixed an issue where tests may terminate unexpectedly.
  • We’ve added support for passing test configuration variables to your Xcode UI Test.
  • We’ve fixed an issue where launching xcuitrunner may fail after ~80 attempts.

WebDriver improvements

  • We’ve fixed the error handling for the device statistics, energy log and network statistics routes. An error message is now displayed in case of an error.

Questions?

Don’t hesitate to reach out to use at info@quamotion.mobi in case you have questions!

Last modified December 23, 2020: Release version 1.4 (b3c343e)